Lexia Cable issues

Yes, place your time and money saving tips here.Nothing illegal or dangerous please!Motoring related only please.

Moderator: RichardW

User avatar
Mandrake
Posts: 8145
Joined: 10 Apr 2005, 17:23
x 307

Re: Lexia Cable issues

Post by Mandrake »

Just ordered a couple of these cheap OBD II extension cables:

http://www.ebay.co.uk/itm/360662847949" onclick="window.open(this.href);return false;

I'll make one into a breakout cable so I can monitor all the data lines with a scope when the 30 pin adaptor is in use and I'm trying to query one of the non responding ECU's. The idea is to find out which data lines the Lexia 3 is querying for each non responding ECU and see if it matches up with the pinouts of the the 30 pin rectangular connector documented further up this thread. (And the wiring diagrams for the car) If it turns out some of the K-Lines are transposed I can make an adaptor cable that "corrects" the wiring for S1 Xantia's when used with a Lexia 3. Will let you guys know if I make any progress! :)

User avatar
Mandrake
Posts: 8145
Joined: 10 Apr 2005, 17:23
x 307

Re: Lexia Cable issues

Post by Mandrake »

If you're reading this Jim, I don't suppose you could look at the S1 V6 wiring diagrams and confirm which pins on the 30 pin diagnostic socket the K-lines for the Air bag, rear view mirror and deadlocks go to ? That would be very helpful :)

User avatar
Stickyfinger
Donor 2016
Posts: 10005
Joined: 28 Mar 2013, 22:05
x 734

Re: Lexia Cable issues

Post by Stickyfinger »

Having the same problem, my Lexia will not read from my S1 V6 Activa.:(

Reads from C5.Mk1, Mk.2, x7...Pug 306/406/206 etc

I have removed the clip, no change.

I have ZERO confidence in changing wires over etc in connectors...so what path to go down ?

User avatar
GiveMeABreak
Forum Admin Team
Posts: 20500
Joined: 15 Sep 2015, 19:38
x 2028

Re: Lexia Cable issues

Post by GiveMeABreak »

test