Citroen Relay 2.2 150 Radio on but no sound

This section is where Audio / Telematics Posts will be placed temporarily

Moderator: RichardW

tomski
Posts: 6
Joined: 06 Sep 2019, 17:49

Citroen Relay 2.2 150 Radio on but no sound

Post by tomski » 06 Sep 2019, 18:04

Hi everyone,
I'm running of ideas. On my citroen relay 2013 2.2 150 radio is working and all the buttons but no sound from speakers. I have checked all the fuses. I have take the whole unit out to see if potentially problem with connection but appeared fine. I have replaced battery recently and not sure if that caused the issue.
Is there anything else I should check?

Many thanks

User avatar
GiveMeABreak
Forum Admin Team
Posts: 18423
Joined: 15 Sep 2015, 19:38
x 1745

Re: Citroen Relay 2.2 150 Radio on but no sound

Post by GiveMeABreak » 06 Sep 2019, 18:50

Pop your VIN up first of all so I can see exactly what you have.

tomski
Posts: 6
Joined: 06 Sep 2019, 17:49

Re: Citroen Relay 2.2 150 Radio on but no sound

Post by tomski » 06 Sep 2019, 20:28

Hi Marc,
VIN: VF7**************[VIN obfuscated, can be read by forum staff]

tomski
Posts: 6
Joined: 06 Sep 2019, 17:49

Re: Citroen Relay 2.2 150 Radio on but no sound

Post by tomski » 07 Feb 2020, 23:16

Still no luck, I have checked the speaker connection behind the unit, all ok. I do get sound from the hands-free unit when mobile connected via Bluetooth but no sound from the radio. All the stations they show on the little screen but no sound. Not sure if there is an amp and maybe that's faulty. Any help appreciated.

User avatar
GiveMeABreak
Forum Admin Team
Posts: 18423
Joined: 15 Sep 2015, 19:38
x 1745

Re: Citroen Relay 2.2 150 Radio on but no sound

Post by GiveMeABreak » 07 Feb 2020, 23:59

Hi - just picked up this thread - it seems I never got back to replying back in September! Whoops, sorry about that.

Ok, I hate to tell you but Citroen commercials are not my favourite as they are essentially Fiats. I have very little on these, especially the Head Units as these are not PSA.

I was about to see what FIAT Head unit you have, but the PSA have taken their site offline for maintenance, so check back later.

User avatar
GiveMeABreak
Forum Admin Team
Posts: 18423
Joined: 15 Sep 2015, 19:38
x 1745

Re: Citroen Relay 2.2 150 Radio on but no sound

Post by GiveMeABreak » 08 Feb 2020, 00:24

Ok, so back up now...
Tomski.PNG
You have item (2) as your Head Unit, plus the telephone interface unit (15) and a KUANTIC telematic module item (40). This thing connects via the GSM network and GPS aerial and can provide mileage and fuel consumption data and allows other devices to be connected. It was originally used for fleet vehicle management to keep an eye on vehicles etc. (Big Brother). So if you have purchased this second hand you may find some of this kit still and spare connectors etc.

I can't tell you why your speakers are not working - there is no separate amplifier - it is integrated into the Head Unit, but if anyone has tried to take out some kit, it may have affected the electrical wiring to or from the Head unit.

User avatar
xantia_v6
Forum Admin Team
Posts: 6980
Joined: 09 Nov 2005, 23:03
x 350

Re: Citroen Relay 2.2 150 Radio on but no sound

Post by xantia_v6 » 08 Feb 2020, 01:14

Does the hands-free kit work through the radio speakers or a separate speaker?

Online
User avatar
white exec
Moderating Team
Posts: 5248
Joined: 21 Dec 2015, 13:46
x 782

Re: Citroen Relay 2.2 150 Radio on but no sound

Post by white exec » 08 Feb 2020, 08:33

Check the van's speaker wiring by disconnecting the speaker connector on the head unit, and applying a battery (1.5v) to each of the speaker pairs (FR, FL, RR, RL etc). You should hear each one 'pop' in turn, if you briefly apply the voltage (which won't harm the speakers). Battery polarity doesn't matter.

While the plug is out (hopefully not a combined one with all the other head unit connections) try connecting a headphone to one of the speaker channels, to see if there is any output.

Connector type may make some of this difficult.

tomski
Posts: 6
Joined: 06 Sep 2019, 17:49

Re: Citroen Relay 2.2 150 Radio on but no sound

Post by tomski » 15 Feb 2020, 00:44

Hi everyone,
Many thanks for all the suggestions. I have been very busy recently unable to play with it.
Didn't get a chance to connect a speaker or battery as suggested but def will try that. One thing worth mentioning... not sure if I read this somewhere when I play music from CD it does work, loud and clear :evil: . Also like I said before hands-free phone connection work. So it's just this bloody radio. I thought it was maybe the aerial but I can choose the station and it appears on the little screen, so it is just the sound not going to the speakers.
Thanks again for all your help.
I will try your idea WHITE EXEC, will let you know.
Tom

Online
User avatar
white exec
Moderating Team
Posts: 5248
Joined: 21 Dec 2015, 13:46
x 782

Re: Citroen Relay 2.2 150 Radio on but no sound

Post by white exec » 15 Feb 2020, 07:46

In that case, speakers and amplifier are both working ok, so no need for the testing I suggested.
For the lack of radio, I can't help much. but do check it out on all wavelengths (LW, MW, FM...) and make sure a Mute button isn't getting pressed by accident.