citroen c5 suspension odd problem

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

martyb2
Posts: 36
Joined: 11 Nov 2004, 22:16

citroen c5 suspension odd problem

Post by martyb2 »

Hi, my c5 has a weird problem, all was working couple of days ago, car not been driven anywhere, and had to raise the suspension to get it into garage, now its stuck in the high position, and all the level indicators are lit up and nothing from the pump. depressurised the rear to change the gaiters on the rear units, and now the back end is sitting on its arse and the front is sitting at the high position and all the lights are still on. AAAAAAAAAAAAARRRRGGGGGHHHHH!!!!!!!!!! its a 2003 hdi model, any ideas before i get half a gallon of petrol and some matches?

Citroenmad
Posts: 8110
Joined: 04 Dec 2008, 23:08
x 28

Post by Citroenmad »

So for some reason the pump is not working? No noises coming from it?

Was it working perfectly before this happened?

Have you tried unplugging the pump and cleaning the contacts and plugging it back in?

martyb2
Posts: 36
Joined: 11 Nov 2004, 22:16

Post by martyb2 »

was working fine couple of days ago, no noises from pump, but not tried unplugging it to check terminals yet, and not sure where the fuse is for it either, more worried about why all the lights have lit up and what it means, although saying that, last week i had the car up on a jack and it lowered and took ages for the pump to cut in and lift back up again, i might add that it has 200,000 miles on it too lol

User avatar
reblack68
Posts: 1047
Joined: 11 Feb 2004, 02:28

Post by reblack68 »

I had a similar problem, turned out to be a bad connection in one of the brake lights!

Citroenmad
Posts: 8110
Joined: 04 Dec 2008, 23:08
x 28

Post by Citroenmad »

reblack68 wrote:I had a similar problem, turned out to be a bad connection in one of the brake lights!
Ah yes, that would do it, the suspension pump does not operate when the brake is pressed.

User avatar
reblack68
Posts: 1047
Joined: 11 Feb 2004, 02:28

Post by reblack68 »

Really? So it wasn't as random as I thought then.

What happened was the centre brake light was on dimly all the time, even with the ignition off. At the same time the car would level when you started, then shortly after it would beep three times and the height indicator would go out. It would stay at that height though.

I tore the car apart looking for any of the many computers it's supposed to have, figuring there would be a bad connection, dry joint or similar. I found none, so I decided to tackle the brake light problem instead. As soon as I touched one of the side brake lights to check it with the meter the brake light problem sorted itself out- a test drive confirmed that the suspension had sorted itself out too.

It always baffled me but it's so obvious now you've pointed it out. :D

martyb2
Posts: 36
Joined: 11 Nov 2004, 22:16

Re: Citroën c5 suspension odd problem

Post by martyb2 »

checked all the fuses, and the maxi fuses, checked the brake light circuit, all fine, and still bugger all, thinking it may well be the pump, unless theres a relay i missed........