Car lost power accelerating then engine stopped. It won't start

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Jetjockey
Posts: 54
Joined: 02 Jun 2019, 22:15
x 1

Re: Car lost power accelerating then engine stopped. It won't start

Post by Jetjockey » 17 Jun 2019, 01:52

Hello Keith.

Just some background information for you. I recently took ownership of a 2008 C5 exclusive tourer. It was about to be scrapped due to the cam belt losing half its teeth and obviously damaging the engine. I replaced all the broken rocker arms, fitted a belt kit and water pump, and reset the inlet camshaft as the drive sprocket had spun approx 90° on the shaft (a real head scratcher)!!! After all this the damn thing still wouldn’t run causing a lot more headscratching. Finally, after plugging in a diagnostic machine (Launch X431 not Lexia), it said “Not enough rail pressure to initiate start”. Long story short it was the injectors, all four suffering huge Leak off and the high pressure pump couldn’t keep up! Now...... there is no pickup pump in the tank or inline, the fuel is sucked up by the low pressure part of the high pressure pump. The dead giveaway (after being told by the diagnostic machine) was that the engine would run all day on easy start, and it purred! The second the easy start was removed the engine would instantly stop. During the periods the engine was running at 1500rpm on easy start, the fuel pressure would rise to approx 100 bar, this was never enough to initiate injection on my 2.0hdi 16v 136bhp engine. Had the four injectors professionally rebuilt and first flick of the key away she went! It’s just a thought but do you have a similar problem?
I would suggest that if it won’t even run on easy start then you have problems other than fuel.

Regards.

KeithJ
Posts: 16
Joined: 28 May 2019, 13:27
x 1

Re: Car lost power accelerating then engine stopped. It won't start

Post by KeithJ » 19 Jun 2019, 23:49

Thank you. I will definitely look into this as the damned thing still won't start.

Oh for the days of a contact breaker and a coil.. :)

Gibbo2286
Posts: 3863
Joined: 08 Jun 2011, 18:04
x 480

Re: Car lost power accelerating then engine stopped. It won't start

Post by Gibbo2286 » 24 Aug 2019, 11:41

Did Keith ever get this started?