berlingo horn and airbag fault! Com2000

Our most popular forum is for Citroën problems, discussions and chat.
Specialising in AX, BX, ZX, Xantia,C5, Xsara, Saxo and XM. CX, 2cv & Berlingo, all are welcome.NOT for selling cars/parts!

Moderator: RichardW

ifred
Posts: 6
Joined: 18 May 2010, 19:04
Location:
My Cars:

berlingo horn and airbag fault! Com2000

Post by ifred » 27 Oct 2010, 17:44

Hi Guys
Sometime ago my airbag light came on when all through the contact cleaning
tricks and tips fix it for a while then it can back fixed it again then it came back intermittent then became a permanent fault
Now I have a none working horn arggh!!!
Taken the airbag of taken steering wheel off clean the Com 2000 rotary connector no joy. I know a new Com 2000 is a lot of pennies for a common weakness of the component.So any good suggestion ?
Also I was thinking I might put the horn on a press button switch on the fixed part of the steering wheel cowling. Can anyone give me an idea how and where to pick up a live feed from?
Any ideas will be appreciated
By the way its a 1.9D 2003 berlingo in Spain :-)
spares are very expensive here as are also the breakers
Cheers
0x

frenchcarnut
Posts: 279
Joined: 24 Jul 2007, 13:08
Location:
My Cars:

Re: berlingo horn and airbag fault! Com2000

Post by frenchcarnut » 27 Oct 2010, 18:16

ifred wrote:Hi Guys
Sometime ago my airbag light came on when all through the contact cleaning
tricks and tips fix it for a while then it can back fixed it again then it came back intermittent then became a permanent fault
Now I have a none working horn arggh!!!
Taken the airbag of taken steering wheel off clean the Com 2000 rotary connector no joy. I know a new Com 2000 is a lot of pennies for a common weakness of the component.So any good suggestion ?
Also I was thinking I might put the horn on a press button switch on the fixed part of the steering wheel cowling. Can anyone give me an idea how and where to pick up a live feed from?
Any ideas will be appreciated
By the way its a 1.9D 2003 berlingo in Spain :-)
spares are very expensive here as are also the breakers
Cheers
Hopefully someone here will be able to help as there are a lot of technically able and helpful individuals on here, but have you also tried the new Berlingo forum?

http://www.berlingoforum.co.uk
0x
04 C5 2.0 Auto HDi VTR

ifred
Posts: 6
Joined: 18 May 2010, 19:04
Location:
My Cars:

Post by ifred » 30 Oct 2010, 09:11

Any help on this guys
Check the Berlingo website its still quite new Will register and post a question
Cheers Chris
0x

User avatar
demag
Donor 2016
Posts: 1412
Joined: 18 Oct 2004, 05:03
Location: Black Country, aye it ar kid.
My Cars: "H" Citroen Bx Tgs Automatic.
2004 Citroen C5 Exclusive Estate 2.2 hdi Automatic.
x 69

Post by demag » 30 Oct 2010, 22:03

There is a "how to" article on there about the com 2000.
0x
Dave

'04 C5 auto estate 2.2 hdi.
Bx 1.6 TGS Auto 50k A rare beast by all accounts. A bit tired but getting better by the day.
'96 XM 2.5TD VSX.......Sadly sold. What an idiot! I should have held on to that.

ifred
Posts: 6
Joined: 18 May 2010, 19:04
Location:
My Cars:

Post by ifred » 31 Oct 2010, 12:14

Yes there is a how to replace the comm 2000 unit from the aussiefrog original. But I need a little more in depth. this stops just where I need the help.
was hoping someone had dismantled the circuit board connection to the ribbon in the rotary connector. This is where I think the fault lies?
If I could take a feed of here for example it might work without an external push switch.
The original design here is really very poor
Regards
Fred
0x

ifred
Posts: 6
Joined: 18 May 2010, 19:04
Location:
My Cars:

Post by ifred » 08 Nov 2010, 17:50

Any help here the Berlingo forum is still a little young and short of posters :(
0x