C5 Mk II 2008 - Front Wipers Not Working (going crazy :) - Motor?

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

User avatar
GiveMeABreak
Forum Admin Team
Posts: 18785
Joined: 15 Sep 2015, 19:38
x 1782

Re: C5 Mk II 2008 - Front Wipers Not Working (going crazy :) - Motor?

Post by GiveMeABreak »

You need to get it diagnosed to identify the correct one - as you should have picked up in this thread that there is a master / slave relationship - so it is possible the fault is in the master controlling unit or the slave unit. Diagbox should help determine this or whether it is another fault. These are self-contained electro-mechanical units independently operating.

sparksie
Donor 2016
Posts: 595
Joined: 04 Jan 2014, 23:35
x 30

Re: C5 Mk II 2008 - Front Wipers Not Working (going crazy :) - Motor?

Post by sparksie »

And, even with the proper Lexia tool, the diagnosis will probably be vague, as it was when I came across this.
Sadly, I have not had a chance to do anything with the wipers, because the car in question seems to have a death wish and has developed ever more disabling faults every time I go near it. It currently only runs in 2nd, 4th, or sometimes reverse, gears, meaning I can't get it to where it needs to go, for someone to help me with it.
I'm following all threads that have anything to do with these, because I just don't know which ones might be relevant. The wiper codes will probably tell you there's no communication between the wiper ecus, which is another way of saying the wipers don't work! It could be either motor, or any part of the harness between the two.
I've yet to drive one of these for any distance, but my initial impression was of a solid, well designed, worthy successor to the Xantia.
It's such a shame all these issues are blighting it.

User avatar
GiveMeABreak
Forum Admin Team
Posts: 18785
Joined: 15 Sep 2015, 19:38
x 1782

Re: C5 Mk II 2008 - Front Wipers Not Working (going crazy :) - Motor?

Post by GiveMeABreak »

There are a substantional number of codes related to the wiper ECUs Sparks, so may be a totally different issue to what you have with yours - and also added to the fact that you have other electrical issues to boot. A proper diagnostic with Lexia should determine whether it is the Slave or Master unit that is at fault.

sparksie
Donor 2016
Posts: 595
Joined: 04 Jan 2014, 23:35
x 30

Re: C5 Mk II 2008 - Front Wipers Not Working (going crazy :) - Motor?

Post by sparksie »

Fingers crossed.
Back in college, as a project, I designed something similar to this system. The idea was to do it using analogue technology and using digital technology, then compare the two. To be honest, my analogue design was much more elegant and simple than the digital one, and used a cheap dc motor, rather than a stepper, as the slave and my conclusion was that analogue was not yet dead.
I would never have thought of using either of them in a harsh environment, however, and I'm not in the least surprised it's turning out less reliable than a single motor with mechanical linkages.
I really think this was an example of "technology for technology's sake", and won't be surprised if the next generation of C5 and 40x do away with it. Even PSA must accept that simply because something is possible is not a good enough reason to do it.
Having said that, the 407 doesn't seem to be as unreliable as the C5, so perhaps the flaws can be engineered out, but the question remains, is there any worthwhile benefit?

rpthomas
New User
Posts: 1
Joined: 15 Feb 2020, 10:37

Re: C5 Mk II 2008 - Front Wipers Not Working (going crazy :) - Motor?

Post by rpthomas »

GiveMeABreak wrote:
24 Mar 2016, 01:19
I think you've already referred to the previous topic on this. - it was the driver's one that needed replacing on mine. I have the procedure here for removing the scuttle and replacing the wiper motors - just send me a Private Message with an email so I can send you the PDFs as they can't be uploaded here (and they are too big to post).
My C5 Tourer 09 plate has just developed exactly this problem, but I can't send you a PM because I'm new to the forum (hunted it down because of this problem and am delighted to find it!). I'd really welcome the PDFs.

Thanks
Richard

User avatar
GiveMeABreak
Forum Admin Team
Posts: 18785
Joined: 15 Sep 2015, 19:38
x 1782

Re: C5 Mk II 2008 - Front Wipers Not Working (going crazy :) - Motor?

Post by GiveMeABreak »

Richard, I have put up the removal guide on the 'How To' section of the Forum here:

How to Remove & Refit the C5 X7 Windscreen Motors