berlingo horn and airbag fault! Com2000

Our most popular forum is for Citroën problems, discussions and chat.
Specialising in AX, BX, ZX, Xantia,C5, Xsara, Saxo and XM. CX, 2cv & Berlingo, all are welcome.NOT for selling cars/parts!

Moderator: RichardW

ifred
Posts: 6
Joined: Tue May 18, 2010 7:04 pm
Location:
My Cars:

berlingo horn and airbag fault! Com2000

Postby ifred » Wed Oct 27, 2010 5:44 pm

Hi Guys
Sometime ago my airbag light came on when all through the contact cleaning
tricks and tips fix it for a while then it can back fixed it again then it came back intermittent then became a permanent fault
Now I have a none working horn arggh!!!
Taken the airbag of taken steering wheel off clean the Com 2000 rotary connector no joy. I know a new Com 2000 is a lot of pennies for a common weakness of the component.So any good suggestion ?
Also I was thinking I might put the horn on a press button switch on the fixed part of the steering wheel cowling. Can anyone give me an idea how and where to pick up a live feed from?
Any ideas will be appreciated
By the way its a 1.9D 2003 berlingo in Spain :-)
spares are very expensive here as are also the breakers
Cheers
0 x

frenchcarnut
Posts: 287
Joined: Tue Jul 24, 2007 1:08 pm
Location:
My Cars:

Re: berlingo horn and airbag fault! Com2000

Postby frenchcarnut » Wed Oct 27, 2010 6:16 pm

ifred wrote:Hi Guys
Sometime ago my airbag light came on when all through the contact cleaning
tricks and tips fix it for a while then it can back fixed it again then it came back intermittent then became a permanent fault
Now I have a none working horn arggh!!!
Taken the airbag of taken steering wheel off clean the Com 2000 rotary connector no joy. I know a new Com 2000 is a lot of pennies for a common weakness of the component.So any good suggestion ?
Also I was thinking I might put the horn on a press button switch on the fixed part of the steering wheel cowling. Can anyone give me an idea how and where to pick up a live feed from?
Any ideas will be appreciated
By the way its a 1.9D 2003 berlingo in Spain :-)
spares are very expensive here as are also the breakers
Cheers
Hopefully someone here will be able to help as there are a lot of technically able and helpful individuals on here, but have you also tried the new Berlingo forum?

http://www.berlingoforum.co.uk
0 x
04 C5 2.0 Auto HDi VTR

ifred
Posts: 6
Joined: Tue May 18, 2010 7:04 pm
Location:
My Cars:

Postby ifred » Sat Oct 30, 2010 9:11 am

Any help on this guys
Check the Berlingo website its still quite new Will register and post a question
Cheers Chris
0 x

User avatar
demag
Posts: 496
Joined: Mon Oct 18, 2004 5:03 am
Location: United Kingdom
My Cars:
x 2

Postby demag » Sat Oct 30, 2010 10:03 pm

There is a "how to" article on there about the com 2000.
0 x
Dave

'10 plate Kia Venga 1.4 crdi.
Bx 1.6 TGS Auto 50k A rare beast by all accounts. A bit tired but getting better by the day.
'01 Reno Scenic Authentique 1.4 - sold
'96 XM 2.5TD VSX.......Sadly sold. What an idiot! I should have held on to that.

ifred
Posts: 6
Joined: Tue May 18, 2010 7:04 pm
Location:
My Cars:

Postby ifred » Sun Oct 31, 2010 12:14 pm

Yes there is a how to replace the comm 2000 unit from the aussiefrog original. But I need a little more in depth. this stops just where I need the help.
was hoping someone had dismantled the circuit board connection to the ribbon in the rotary connector. This is where I think the fault lies?
If I could take a feed of here for example it might work without an external push switch.
The original design here is really very poor
Regards
Fred
0 x

ifred
Posts: 6
Joined: Tue May 18, 2010 7:04 pm
Location:
My Cars:

Postby ifred » Mon Nov 08, 2010 5:50 pm

Any help here the Berlingo forum is still a little young and short of posters :(
0 x


Return to “Citroën”

Who is online

Users browsing this forum: Bing [Bot] and 6 guests