206 engine warning light on no power to OBDII port

This is the Forum for all your Peugeot Technical Questions, Problems or Advice.

Moderator: RichardW

Homer
Posts: 1457
Joined: 26 Feb 2003, 11:52
x 5

206 engine warning light on no power to OBDII port

Post by Homer » 06 Sep 2018, 08:57

My daughter's 2003 Peugeot 206 1.4 8 valve petrol has the engine warning light on. Car starts and runs fine, no symptoms to go on apart from the light.

Plugged my bluetooth OBDII reader in and it doesn't seem to get any power.

Didn't have much time to mess around with it but swapped fuse 5 which I think is the right one for the diagnostic port power and still not getting anything. I checked the reader works on another car and as far as I know it should work in the 206.

Any ideas? It will be Sunday before I can really have a proper go at it though.

Online
User avatar
GiveMeABreak
Forum Admin Team
Posts: 11062
Joined: 15 Sep 2015, 19:38
x 933

Re: 206 engine warning light on no power to OBDII port

Post by GiveMeABreak » 06 Sep 2018, 09:16

Battery is weak or Economy mode? Have you tried with engine running too? Pop up your VIN and I’ll check the electrical diagram

Homer
Posts: 1457
Joined: 26 Feb 2003, 11:52
x 5

Re: 206 engine warning light on no power to OBDII port

Post by Homer » 06 Sep 2018, 12:50

Cheers

Battery is pretty new but I started the engine with the reader in just in case.

VIN: VF3**************[VIN obfuscated, can be read by forum staff]********
Last edited by GiveMeABreak on 06 Sep 2018, 17:16, edited 1 time in total.
Reason: VIN Masked

Online
User avatar
GiveMeABreak
Forum Admin Team
Posts: 11062
Joined: 15 Sep 2015, 19:38
x 933

Re: 206 engine warning light on no power to OBDII port

Post by GiveMeABreak » 06 Sep 2018, 13:24

Ok I’m out now but will check as soon as I’m back

Online
User avatar
GiveMeABreak
Forum Admin Team
Posts: 11062
Joined: 15 Sep 2015, 19:38
x 933

Re: 206 engine warning light on no power to OBDII port

Post by GiveMeABreak » 06 Sep 2018, 17:16

Ok, well unfortunately the diagrams are so old they don't contain anything useful from 2003 on this car - they don't even list the fuses to components, so can't really help - but it will no doubt either be a fuse or a pin on the diagnostic port may be knocked out of alignment I suspect.

I even checked the manual for your car for the year and although that has the fuses listed - you guessed it - not a single mention of the diagnostics port! :roll:

Online
User avatar
Paul-R
Posts: 2775
Joined: 07 May 2009, 16:24
x 157

Re: 206 engine warning light on no power to OBDII port

Post by Paul-R » 06 Sep 2018, 17:25

My daughter's old 206 had such a problem and it was indeed bent contacts in the socket. In fact those bent contacts actually caused the matching contacts in the plug to become distorted and they also needed straightening afterwards!

Online
User avatar
GiveMeABreak
Forum Admin Team
Posts: 11062
Joined: 15 Sep 2015, 19:38
x 933

Re: 206 engine warning light on no power to OBDII port

Post by GiveMeABreak » 06 Sep 2018, 17:36

There you go then ^ likely suspect.

Homer
Posts: 1457
Joined: 26 Feb 2003, 11:52
x 5

Re: 206 engine warning light on no power to OBDII port

Post by Homer » 07 Sep 2018, 07:49

Cheers, will have a good look at it on Sunday and get the multimeter out.

I got fuse 5 from the Book Of Lies so it may not be right, I think it's listed there as automatic gearbox and diagnostic socket but then it could be just the diagnostic socket for the automatic gearbox (car is a manual).

Car still runs fine the only thing she says seems different is when it's ticking over the revs used to fluctuate slightly and now it sits steady at a little below 1000RPM

Homer
Posts: 1457
Joined: 26 Feb 2003, 11:52
x 5

Re: 206 engine warning light on no power to OBDII port

Post by Homer » 10 Sep 2018, 10:01

Pins looked fine. No power to pin 16. Started checking the other fuses, and found fuse 1 blown. According to the manual that is supposed to be the alarm siren. Replaced it and the OBDII port is now working.

No codes found though so I guess it needs the equivalent of a Lexia, Peugeot Planet is it?

Homer
Posts: 1457
Joined: 26 Feb 2003, 11:52
x 5

Re: 206 engine warning light on no power to OBDII port

Post by Homer » 15 Sep 2018, 00:25

Turned out to be O2 sensor bank 1.

That has been replaced and after running fine for a few days it suddenly won't tick over when cold.

Nipped out of work to take a look. Revved it for a minute or two until it settled down, symptoms were pretty much how a cold engine would have been with no choke back in the carburettor days. Drove it round the carpark and handed her it back to drive home. No time to do anything since I had to get back to work.