Non Starter

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

andyroo
Posts: 2
Joined: 05 Oct 2018, 16:26

Non Starter

Post by andyroo » 05 Oct 2018, 16:36

Hi Guys, my name is Andy and im new to this forum and would like some advice if poss.
I have a c4 VTR+ that has stood on my drive for over a year due to me having an injury that left me unable to drive. I removed the battery some months ago. But recently after deciding to get rid of the car I bought a new battery in the hope of the car of starting up. ( naïve I know ). However after connecting said battery it has had no affect, as nothing happens when you turn the ignition, no lights on dash or anything. Any ideas what the problem could be? I really have little knowledge on cars and cant afford to spend loads on repairs. So any advice you could give me would be gratefully appreciated..

Online
User avatar
GiveMeABreak
Forum Admin Team
Posts: 10688
Joined: 15 Sep 2015, 19:38
x 889

Re: Non Starter

Post by GiveMeABreak » 05 Oct 2018, 16:40

Hi and welcome.

There are certain procedures that need to be followed when disconnecting and reconnecting a battery on PSA cars. Just to clarify, can you confirm whether the car tries to turn over but won't start, or are you saying it is completely dead? So I also assume the central locking is not working either?

First thing I would do is check the actual battery terminals for any corrosion as it has been sitting for a year there is bound to be some water ingress / damp that will affect the car more when left standing than being run regularly. I would give all the staring wiring a check over, the fuse box and make sure there is nothing obvious. Clean the battery contacts up too. If you are still not getting any dash lights then there is no power getting to the starting circuit so start checking fuses in the engine bay fuse box too.

Can you pop up your VIN so we can determine exact model and kit please.

andyroo
Posts: 2
Joined: 05 Oct 2018, 16:26

Re: Non Starter

Post by andyroo » 05 Oct 2018, 17:47

Thanks for the reply Marc, when I connect the battery it is totally dead.
The VIN is VF7**************[VIN obfuscated, can be read by forum staff]