Speedo and odometer not working

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Raul
Posts: 116
Joined: 05 May 2012, 05:37

Speedo and odometer not working

Post by Raul » 17 Sep 2018, 13:44

Hi

I think the transducer in broken. Could somebody tell what is the oem part number of the transducer so that I could place an order to it. The car is citroen berlingo 2.0 hdi from 2003.

User avatar
GiveMeABreak
Forum Admin Team
Posts: 11584
Joined: 15 Sep 2015, 19:38
x 989

Re: Speedo and odometer not working

Post by GiveMeABreak » 17 Sep 2018, 14:08

This? Speed Control
Transducer.PNG
Transducer.PNG (31.1 KiB) Viewed 100 times
Part: 616070 Price (UK): £80.29 inc. VAT

User avatar
xantia_v6
Forum Admin Team
Posts: 5795
Joined: 09 Nov 2005, 23:03
x 236

Re: Speedo and odometer not working

Post by xantia_v6 » 17 Sep 2018, 14:15

The same part is used on almost every PSA vehicle since 1994, there are lots of cheap clones (of varying quality), and second-hand genuine ones available.

Raul
Posts: 116
Joined: 05 May 2012, 05:37

Re: Speedo and odometer not working

Post by Raul » 05 Oct 2018, 10:29

Changed for the new one. Still both speedo and odo do not work . One thing I noticed that when I last time filled up diesel I put the trip counter to zero and it has read 300 meter for the full tank. What should I look next.
I connected lexia to the car and got followining faults.
Under "Display and Telematics": Intermittent fauls , No permanent positive of the display

Under Injection: Prep-post heating relay citcuit Short circuit to earth or open circuit

I checked the fuses and they seem ok. Looks like there is a bad connection somewhere.

I also connected the cruise control stick and enabled it during lexia session. Needless to say it does not work at the moment.

Raul
Posts: 116
Joined: 05 May 2012, 05:37

Re: Speedo and odometer not working

Post by Raul » 09 Oct 2018, 19:25

Turns out the drive pinion inside the diff is broken. I already got the spare part but the haynes manual says that I also need to renew the gasket that sits between the pinion housing and diff. It takes at least a week before the gasket arrives. Should I try to reuse the gasket or wait for the new gasket?